備忘録のため,内容の正当性については責任を持ちません。

Mac OS 10.6.7 (Snow Leopard) に Perl のフレームワーク Catalyst をインストールした。若干手こずったので方法をメモしておく。


Xcode のインストール

make などのコマンドを使えるようにするために,Xcode をインストールする。


Perl 5.12 のインストール

デフォルトで入っている Perl 5.10 では,cpan で Catalyst をインストールする際に unknown error となるため,perlbrew を用いて Perl 5.12 をインストールする。

まず perlbrew を用意する。

$ curl -LO http://xrl.us/perlbrew
$ perl ./perlbrew install
$ rm perlbrew
$ ~/perl5/perlbrew/bin/perlbrew init
$ echo 'source ~/perl5/perlbrew/etc/bashrc' >> ~/.bashrc
$ source ~/.bashrc

Perl 5.12.3 をインストールする。

$ perlbrew install perl-5.12.3
$ perlbrew switch perl-5.12.3

Perl 5.12.3 が入った。

$ perl -v

This is perl 5, version 12, subversion 3 (v5.12.3) built for darwin-2level
(以下略)

起動時に ~/.bashrc を読み込むようにする。

$ vi ~/.bash_profile
if [ -f ~/.bashrc ] ; then
  . ~/.bashrc
fi

Catalyst をインストール

準備が整ったので cpan で Catalyst をインストールする。

$ perl -MCPAN -e "install Catalyst::Devel"

以上でインストールが完了した。

コメント

コメントする




CAPTCHA